Disk Usage Exceeds Limit 95 Percent After Upgrade To PAN-OS 10.2.0
57500
Created On 04/12/22 19:28 PM - Last Modified 08/09/22 20:22 PM
Symptom
- After upgraded Firewall to PAN-OS 10.2.0 the root partition is filling up over 90%
> show system disk-space Filesystem Size Used Avail Use% Mounted on /dev/root 3.8G 3.4G 235M 94% / none 2.0G 60K 2.0G 1% /dev
- Looking at the output of the CLI command debug techsuppport duts run there is a large sslvpn_ngx_error.log file growing
> debug techsupport duts run /var depth 4 ==================================================== 580M /var/log/pan/sslvpn_ngx_error.log/pan/sslvpn_ngx_error
- When viewing the sslvpn_ngx_error.log output we can see the logging level is set to debug where on 10.1.x it was set to Info
> tail follow yes mp-log sslvpn_ngx_error.log 2022/04/11 08:43:39 [debug] 9104#0: http file cache expire 2022/04/11 08:43:39 [debug] 9104#0: malloc: 000000FFD8002240:56 2022/04/11 08:43:39 [debug] 9104#0: http file cache size: 0 c:0 w:-1 2022/04/11 08:43:39 [debug] 9104#0: http file cache manager: 0 e:0 n:10000 2022/04/11 08:43:39 [debug] 9104#0: event timer add: -1: 10000:1108205850 2022/04/11 08:43:39 [debug] 9104#0: epoll timer: 10000
Environment
PAN-OS 10.2.0
Cause
This has been identified by bug PAN-190923. The sslvpn nginx has "debug" level logging by default which possibly caused much more logging at "debug" level.
Resolution
This fix for bug PAN-190923 is targeted for PAN-OS 10.2.1.
Workaround
- Delete the large sslvpn_ngx_error.log file from the CLI to free up Disk Space on root.
> delete debug-log mp-log file sslvpn_ngx_error.log sslvpn_ngx_error.log 2022/04/06 10:03:38 53240.1K