Log Collector showing 'Out of Sync' due to "IP mismatch for mgmt interface"
11299
Created On 04/12/23 03:14 AM - Last Modified 09/15/23 04:11 AM
Symptom
- Changed Log Collector's IP from 10.46.33.127 to 10.46.33.7 from Log Collectors CLI using set deviceconfig system ip-address
# set deviceconfig system ip-address 10.46.33.7
- From Panorama > Manage Collectors the status shows "Out of sync"
- From the output of configd.log we get the error below
> less mp-log configd.log
2023-04-05 19:06:02.649 -0700 waiting to complete load ring job
/opt/pancfg/mgmt/cgroups/myCG/017607000309-ip.xml:2: parser error : Extra content at the end of the document
<ipaddr>10.46.33.127</ipaddr>
Environment
- Panorama
- Log Collector
- PAN-OS version 10.0 and above
- To make sense of the IP addresses used in this article, we'll use the topology below as a reference
Cause
The error occurred due to two different IP addresses being used. The Log Collector's configured IP address in Panorama is 10.46.33.127 (original), but it is now connecting with a new IP address of 10.46.33.7, which was not previously configured in Panorama and is therefore unknown to it. As a result, we have a configuration error "IP mismatch for mgmt interface".
Resolution
- Go to Panorama > Manage Collectors > COLLECTOR NAME
- Go to Collector > Interfaces > Management
- Change the IP addressing parameters accordingly
- click OK > OK
- To Commit, Click on Commit > Commit to Panorama > Commit
- To send the config from Panorama to the Log Collector, Click on Commit > Push to Devices > Edit Selections > Collector Group > check the appropriate CG > OK > Push
- If the output matches the one displayed above, it confirms that we have achieved our goal successfully.
Additional Information
How to change the IP address of Log Collector