WAAS reporting error "failed sending request : context canceled" in WAAS Connectivity Monitor and Prisma Cloud Defender Logs
8965
Created On 05/13/22 07:50 AM - Last Modified 05/17/22 00:25 AM
Symptom
- Client to Server communication failing with WAAS module reporting following error in WAAS Connectivity Monitor and Prisma Cloud Defender Logs.
DEBU 2022-04-28T12:12:08.450 2022-04-28T11:31:13.957 failed sending request: Post http://localhost:8081/xxxx/xxxx/search_order.jsp: context canceled, route: "10.10.xx.xx:8081/xxxxx/xxx/search_order.jsp", request inspection duration: "0 ms", total serve duration: "84148 ms"
- Most Common Network Scenario : Client > Internet > WAAS > Web/Application Server
Environment
- Prisma Cloud Compute Saas
- Prisma Cloud Compute Self-hosted version 21.04 and above
Cause
- “context canceled” often indicates network connection issues between the Defender and the Application Server.
- This may also occur owing to inconsistency with different Proxy Environments (Eg. Scenario: Internet > Reverse Proxy > WAAS > Web Server).
- This may also imply hitting the Read timeout (sec) Limit for the particular WAAS Policy.
Resolution
- Check Application Server Logs for any Application specific errors during time of issue (eg. ESOCKETTIMEDOUT may be observed if a WebServer failed to find the "Accept-Encoding" header in the HTTP Request Header).
- Review the configuration for "Read timeout (sec)": Compute > Defend > WAAS > WAAS policy > WAAS Rule > Actions > Edit > Advanced proxy settings
NOTE: This can also be referred as the Proxy timeout that indicates the maximum duration in seconds for reading the entire request, including the body. A 500 error response is returned if a request is not read within the timeout period. For applications dealing with large files, adjusting the proxy timeout is necessary.