Global Protect client fails to connect with error "Could not connect to GlobalProtect service" after upgrading to Windows 11 on the user machine.

Global Protect client fails to connect with error "Could not connect to GlobalProtect service" after upgrading to Windows 11 on the user machine.

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Created On 10/28/23 02:09 AM - Last Modified 06/22/24 03:53 AM


Symptom


  • Global Protect client is installed and working well on Windows 10.  Upgrading the OS to Windows 11 breaks  the client and it can no longer connect.
  • A complete uninstallation and reinstallation of the GlobalProtect client on Windows 11 also does not help.
  • The PanGPS service is actually running on the windows. 
  • When the Windows is upgraded to Windows 11 via task sequence ((re-imaging the OS), the GP does not have any issues.
  • When the Windows is upgraded to Windows 11 via (In place upgrade), that's when the GP client cannot connect.
Failed to connect to GlobalProtect service


Environment


  • Global Protect client for Windows.
  • Strata NGFW
  • Prisma Access for Users.


Cause


  • As the error indicates, one of the process for Global Protect client is unable to connect to another process called PanGPS.
  • This is caused by the failure of the driver copy during the installation process. The logs can found under setupapi.dev.log. Follow these steps to collect GlobalProtect Client logs. 
  ---(output omitted)----
 CopyFile: 'C:\Program Files\Palo Alto Networks\GlobalProtect\pangpd.sys' to 'C:\WINDOWS\System32\DriverStore\Temp\{2c214b7e-2393-124a-a8b7-efef960ee782}\SET92EE.tmp' FAILED
!    flq:                Error 87: The parameter is incorrect.
!!!  flq:                Error installing file (0x00000057)
!!!  flq:                Error 87: The parameter is incorrect.
!    flq:                     SourceFile   - 'C:\Program Files\Palo Alto Networks\GlobalProtect\pangpd.sys'
!    flq:                     TargetFile   - 'C:\WINDOWS\System32\DriverStore\Temp\{2c214b7e-2393-124a-a8b7-efef960ee782}\pangpd.sys'
!!!  cpy:                Failed to copy file 'C:\Program Files\Palo Alto Networks\GlobalProtect\pangpd.sys' to 'C:\WINDOWS\System32\DriverStore\Temp\{2c214b7e-2393-124a-a8b7-efef960ee782}\pangpd.sys'. Error = 0x00000057
!!!  flq:                SPFQNOTIFY_COPYERROR: returned SPFQOPERATION_ABORT.
!!!  flq:                Error 995: The I/O operation has been aborted because of either a thread exit or an application request.
!!!  flq:                Failed to commit copy queue. Error = 0x000003e3
!!!  flq:                FileQueueCommit aborting
!!!  flq:                Error 995: The I/O operation has been aborted because of either a thread exit or an application request.
     flq:           {FILE_QUEUE_COMMIT - exit(0x000003e3)} 11:00:27.636
!!!  sto:           Failed to copy driver package files. Error = 0x00000057
!!!  sto:           Failed to import driver package into Driver Store. Error = 0x00000057
----(output omitted)-----------
  • This is not GlobalProtect app issue but an issue with the a 3rd party software which is causing the windows to fail to copy the driver files during installation.
  • Running a process monitor debug on the Windows during the installation and sharing it with the Microsoft team will help isolate which 3rd party app is causing the issue.  More details in the additional details section.


Resolution


  1. Test by installing the GlobalProtect client on a new Windows 11 machine without any other end point security packages.
  2. Work with the local IT team or Microsoft to identify why the driver files fails to copy.
  3. Run process monitor debug on the Windows during the installation and sharing it with the Microsoft team will help them identify the exact app responsible for the issue.
  4. Uninstall the app identified and the issue will be fixed. 
  5. Alternatively, perform step by step isolation by installing/uninstalling each 3rd party app to find which one is causing the permissions issue. 
Note: 3rd party apps which control the permissions on Windows might cause this kind of issue. 


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