GlobalProtect 5.2.x or above fails to install package when using the apt-get utility on Ubuntu 20.04.

GlobalProtect 5.2.x or above fails to install package when using the apt-get utility on Ubuntu 20.04.

22084
Created On 03/25/22 20:52 PM - Last Modified 03/31/22 19:39 PM


Symptom


When installing the GlobalProtect 5.2 or above CLI-only or GlobalProtect UI-CLI 6.0 or above package on Ubuntu 20.04 using the apt-get utility we see the following errors in the terminal: 

apt-get installation errors when installing the CLI-only package for GlobalProtect 5.2 or above: 

$ sudo apt-get install ./GlobalProtect_deb-5.3.3.0-3.deb
Reading package lists... Error!
E: read, still have 59 to read but none left
E: Error reading archive member header
E: Could not read meta data from /home/user1/globalprotect/GlobalProtect_deb-5.3.3.0-3.deb
E: The package lists or status file could not be parsed or opened.

apt-get installation errors when installing the UI-CLI package for GlobalProtect 6.0 or above:

sudo apt-get install ./GlobalProtect_UI_deb-6.0.0.1-44.deb 
Reading package lists... Error!
E: read, still have 59 to read but none left
E: Error reading archive member header
E: Could not read meta data from /home/user1/Desktop/GP-60/PanGPLinux-6.0.0-c18 (1)/GlobalProtect_UI_deb-6.0.0.1-44.deb
E: The package lists or status file could not be parsed or opened.
 

 



Environment


  • GlobalProtect on Linux Ubuntu Debian
  • GlobalProtect 5.2 and above when using CLI version.
  • GlobalProtect 6.0 and above when using UI-CLI version.
  • Ubuntu 20.04 Desktop & Server 


Cause


When trying to install the GlobalProtect Linux Debian package on Ubuntu 20.04, the apt-get utility cannot read the package dependencies for the GlobalProtect installation due to underlying OS limitations.   

Resolution


Workaround: 
The workaround for installing the GlobalProtect app on Ubuntu 20.04 is to use the dpkg utility instead of the apt-get utility.

CLI-Only:
The following command can be used to install the CLI-Only GlobalProtect Client 5.2.x or above:

$ sudo dpkg -i GlobalProtect_deb-5.3.3.0-3.deb

UI-CLI:
For the UI-CLI version supported from GlobalProtect 6.0 or above, you will need to install the libqt5webkit5 dependencies via apt-get, then install the GlobalProtect package with dpkg utility. 

$ sudo apt-get install libqt5webkit5
$ sudo dpkg -i GlobalProtect_UI_deb-6.0.0.1-44.deb


Additional Information


  • If upgrading the Linux Ubuntu OS from 18.04 or 19.04 to 20.04, GlobalProtect should work as expected. 
  • Upgrading from an older GlobalProtect 5.3.x version to the latest 5.3.x on Ubuntu 20.04 should work as expected.  
  • Upgrading GlobalProtect from 5.3.x to 6.0.x should work as expected for CLI. If you wish to switch to UI-CLI version using GlobalProtect Linux 6.0 or above, you will need to uninstall the CLI-only version, then install the UI-CLI version. For uninstall please refer to the following document.   

 

 



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u0000004NoDCAU&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language