GlobalProtect agent shows "Connecting" or "Still Working" in System tray GUI even when connected
45726
Created On 01/18/22 16:48 PM - Last Modified 08/29/22 21:19 PM
Symptom
- GlobalProtect agent shows "Connecting" or "Still Working" in System tray GUI and user shows connected in the firewall Web GUI.
- GP client 'Connection' tab is empty with no output.
- PanGPS logs display "Error processing receive data" and other errors
(P4788-T7276)Error( 370): 11/10/21 14:01:57:885 read() failed: 10054
(P4788-T7276)Info ( 219): 11/10/21 14:01:57:885 Error processing receive data from client
(P4788-T7276)Info ( 228): 11/10/21 14:01:57:885 close client socket
Environment
- GlobalProtect App for Windows
Cause
This error message in PANGPS logs indicates an issue with the installation / upgrade process.
Resolution
- Completely remove GlobalProtect from the client machine and reinstall.
- Disable WMI services : run - services.msc - Windows Management Instrumentation(WMI) - stop the service.
- Delete the files under C:\Windows\System32\wbem\Repository
- Open regedit
Go to HKEY_LOCAL_MACHINE > Software and HKEY_CURRENT_USER > Software. Delete the Palo Alto Networks folder. - Delete the same if the same folder is present in any other user under HKEY_USERS.
- Un-install GlobalProtect from Windows 'program and features'.
- Make sure that the virtual adapter in not present in the Network adapter settings.
- Reboot the machine.
- Reinstall GlobalProtect with admin privileges.
- Confirm that WMI service is running.