“Invalid Auth Code” prompted when registering new PA-VM

“Invalid Auth Code” prompted when registering new PA-VM

6949
Created On 03/12/20 15:00 PM - Last Modified 04/06/20 22:34 PM


Symptom


Auth code supplied has been registered with Customer Support Portal account under Assets > “VM-Series Auth-Codes” but attempts to activate the license on firewall results in error with prompt “Failed to install Licenses. Invalid Auth Code” or “License is invalid”'
 
 
  • Collect the CPUID and UUID from the PA-VM firewall either from WebUI > Dashboard or using below CLI command:
> show system info
...
family: vm
model: PA-VM
serial: unknown
vm-mac-base: 7C:89:C1:27:8C:00
vm-mac-count: 256
vm-uuid: 247D7903-0A84-4E58-9EEF-58D2D48416F2
vm-cpuid: KVM:54060500FFFB8B0F
vm-license: none
vm-mode: KVM
cloud-mode: non-cloud
sw-version: 9.0.4


Environment


  • Platform: PA-VM
  • PAN-OS / Plugin Version: Any
  • Deployment: Any


Cause


  • Hypervisor section (“AZR:”, “ESXI:”, “NSX:”, etc.) is left out in CPUID. This is required in PAN-OS 8.0 or later
  • CPUID and UUID are often accidentally reversed by admins while registering a new Virtual Machine on Customer Support Portal probably due to it being listed in flipped order when compared to the firewall

 


Resolution


  • Engage Support Team to compare CPUID and UUID from the PA-VM instance with the current CPUID and current UUID associated with the serial number on License server
  • Once the engineer edits the CPUID and UUID (if mismatch is found) on backend server to match with the PA-VM instance, attempt to retrieve license again on PA-VM if it has reachability to update server over the Internet.
  • In case the PA-VM instance has no access to Internet, license files should be re-downloaded from the support portal after the changes are made on license server and should be manually uploaded to the firewall.


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000PP1WCAW&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail