License Error: "Failed to Install Licenses. Unexpected Error Occurred"

License Error: "Failed to Install Licenses. Unexpected Error Occurred"

138261
Created On 09/26/18 13:48 PM - Last Modified 06/18/25 07:50 AM


Symptom


When updating licenses the following error is displayed:

Failed to install licenses. Unexpected Error occurred.



Environment


  • NGFW
  • Supported PANOS versions


Cause


The error message above indicates that the license file is corrupted, and the Palo Alto Networks devices cannot install this license file automatically.



Resolution


  1. Navigate to the Palo Alto Networks Support Portal (https://support.paloaltonetworks.com) and log in.
  2. Go to the Assets tab and find the serial number of the device in question.
  3. Manually download each license needed.
  4. On the Palo Alto Networks firewall GUI, go to Device > Licenses. Then, choose "Manually upload license key"
  5. Install the license files, one at a time.

Refresh the page and the licenses should now be correct.



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000ClpDCAS&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language