Prisma Access Error message "Failed to backup config. Reason: XXXX"?

Prisma Access Error message "Failed to backup config. Reason: XXXX"?

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Created On 08/15/24 07:54 AM - Last Modified 10/18/24 21:06 PM


Symptom


plugin_cloud_services.log displays the error message "Failed to backup config. Reason: XXXX"

INFO: [daemon] Triggering auto-backup!
ERROR: [config-backup] Failed to backup config. Reason: No certificate or certificate is invalid.
ERROR: [daemon] Failed to run auto-backup. argument of type 'bool' is not iterable


Environment


  • Prisma Access
  • Panorama
  • Supported PAN-OS versions


Cause


Prima Access unable to connect to the backup server.



Resolution


  1. The error message is related to the config auto-backup feature for Prisma Access.
  2. Every night Prisma Access saves a backup of the Panorama running configuration, but if the attempt fails, the error message "Failed to backup config. Reason: XXXX" will be generated.
  3. If the error message continue then the connectivity between the backup server and Prisma access need to be checked.

Here are the details explained in help page

GUI: Panorama > Cloud Services > Configuration > Service Setup> Service Operations > Download and save Prisma Access configuration snapshot

  • Every night Prisma Access saves a back up of the Panorama running configuration.  If you need to restore the previous night's configuration on your Panorama, click the Download and save Prisma Access configuration snapshot and enter a name for configuration snapshot. When the configuration snapshot is successfully retrieved from the cloud service, to load the snapshot, go to Panorama > Set up > Operations > Load named Panorama configuration snapshot and select the filename you entered.

 



Additional Information


  • The error message "Failed to backup config. Reason: XXXX" that could be printed to plugin_cloud_services.log is sometimes mixed up as an error message coming from the "Scheduled Config Export" feature.
  • The "Failed to backup config. Reason: XXXX", has nothing to do with the "Scheduled Config Export" feature. 
  • For the Error message generated by the "Scheduled Config Export" Refer Failed to Export Configuration Bundle with Error Code 9 on Panorama/M-100

     


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