Unable to commit receiving "other administrators are holding device wide commit locks" error

Unable to commit receiving "other administrators are holding device wide commit locks" error

20890
Created On 05/24/23 22:04 PM - Last Modified 09/12/23 21:29 PM


Symptom


Not able to commit the changes.

Environment


  • Palo Alto Firewall or Panorama
  • Supported PANOS
  • Commit


Cause


  • If "Automatically Acquire Commit Lock " is enabled, when multiple admins make changes to the firewall, the Commit Lock will be taken by the administrator.
  • If any of the admins try to do a partial commit, it will throw an error "Other administrators are holding device-wide commit locks."
  • This option is used to prevent collisions that can occur when two administrators are making changes at the same time.
COMMIT 1.jpg
 


Resolution


Solution 1:
Perform full commit after previewing the changes to ensure changes done by other admin users are taken care of.

 

Solution 2:
Remove the commit lock via GUI. For more information on this check How to Remove Configuration Lock

Solution 3: 
Remove the commit lock via CLI. First check which admins hold the commit lock using the below command:
> show commit-locks

If you are a superuser and you see commit locks from the CLI command above, they can be cleared using the below command.

> request commit-lock remove

 



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000g1wTCAQ&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail