GP Agent cannot connect to GW due to the error "The virtual adapter was not set up correctly due to a delay"

GP Agent cannot connect to GW due to the error "The virtual adapter was not set up correctly due to a delay"

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Created On 04/11/23 10:11 AM - Last Modified 06/13/23 07:30 AM


Symptom


  • The GP agent is not able to connect to a gateway and the logs show the error "The virtual adapter was not set up correctly due to a delay. GlobalProtect will try again soon. If the issue persists, please restart your system."
  • Certain GP logs are not correctly populated like systeminfo.log, serviceinfo.log, or nicinfo.log.


Environment


  • OS Windows 10 and Windows 11.
  • Any GP agent version.


Cause


  • For some reason, WMI(Windows Management Instrumentation) is not working properly.
  • Since GP Agent relies on WMI to run some tasks, the WMI problem impacts the normal working of GP agent.


Resolution


  1. Generate GP logs.
  2. Confirm the GP agent is correctly installed, open the logs setupapi.dev.log, and check the driver installation: 
    The following output indicated the GP agent is correctly installed:           

     >>>  [Install network driver - PanGpd]
    --- Ommitted putput ----
         dvi: Install finished for ROOT\PANGPD\0000
    --- Ommitted putput ----
    <<<  [Exit status: SUCCESS]

    If the Agent is not correctly installed, uninstall and install again following the instructions in the next KB Article.                               
    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000Cm5eCAC 
     

  3. Check the log serviceinfo.log, that log gets information directly using WMI. If the log shows the following output  or similar, there is a problem with the WMI:
    ERROR:
    
    Description = Invalid namespace

    You can also check other logs to confirm like ProcessInfo.log or NicConfig.log.   
                                                                              

  4. Open cmd as administrator and run the following command to check the WMI:

    wmimgmt.msc 

    The next screen will appear:                                                                                                                                                                        image.png


    From there, right-click on WMI Control (local) > properties, and a successful connection should be seen, if it is not able to connect the WMI, this confirms the WMI problem.

    image.png


    Example of a successful connection:

    image.png
     

  5. In the CMD, run the following command to confirm if the repository is OK:
    winmgmt /verifyrepository

    If the output is different than "WMI Repository is consistent", there is a problem with WMI repository, the following commands can help to fix the repository issue:

    winmgmt /salvagerepository
    winmgmt /resetrepository
    
  6. If until now, the issue persists, run the following script using the CMD (this can take some minutes):
    @echo off
    sc config winmgmt start= disabled
    net stop winmgmt /y
    %systemdrive%
    cd %windir%\system32\wbem
    for /f %s in ('dir /b *.dll') do regsvr32 /s %s
    wmiprvse /regserver
    winmgmt /regserver
    sc config winmgmt start= auto
    net start winmgmt
    for /f %s in ('dir /s /b *.mof *.mfl') do mofcomp %s
  7. Once the script finishes, check again the WMI status (Step 4), if the issue persists, contact Microsoft support to get help on how to fix the WMI problem.



Additional Information




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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000g1J2CAI&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail