SAML と証明書認証の両方を使用すると、iPhone または iPad 上の GlobalProtect アプリは接続できません。

SAML と証明書認証の両方を使用すると、iPhone または iPad 上の GlobalProtect アプリは接続できません。

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Created On 08/31/23 00:28 AM - Last Modified 01/07/25 02:33 AM


Symptom


  • IOS (iPhone または iPad) 上の GlobalProtect (GP) クライアント アプリで、「インターネット接続がオフラインのようです」というエラー メッセージが表示されます。
  • これは、接続方法がオンデマンドに設定されている場合に発生します。(SAML を使用する場合にのみサポートされる方法)
  • GP ポータルでは、認証は「いいえ (ユーザー資格情報とクライアント証明書が必要)」に設定されており、SAML と証明書の両方の認証が必要であることを意味します。
  • 認証方法の 1 つ (SAML のみ、または証明書のみ) が使用されている場合、GPアプリケーションは問題なく接続できます。
The Internet connection appears to be offline


Environment


  • IOS (iPhone または iPad) 上の GlobalProtect クライアント アプリ
  • モバイルユーザー向けPrisma Access
  • Strata NGFW 上の GlobalProtect。


Cause


  • これは、IOS のMDM (モバイル デバイス管理) が識別子のアプリケーションルールを使用して構成されている場合に発生します。
  • GP サポート バンドルログの Agent.log ファイルには次のように表示されます。
onDemandEnabled = YES
    appRules = (
        {
            matchSigningIdentifier = com.paloaltonetworks.globalprotect.vpn
        },
        {
            matchSigningIdentifier = com.esri.fieldmaps
        },


Resolution


  1. MDMチームと協力して識別子の設定を削除します。
  2. Microsoft Intuneの場合、vpn 設定は以下に示すように none にする必要があります。
Intune MDM without identifier
  1. GlobalProtectポータル設定が次の条件と一致かどうかを検証します。
  2. SAML のデフォルトブラウザが有効で、 接続方法 = 「オンデマンド」
  3. GP クライアントアプリケーションは、 認定されたMDMによって管理されます。


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