GlobalProtect App on Iphone or Ipad unable to connect when using both SAML and certificate authentication.
8132
Created On 08/31/23 00:28 AM - Last Modified 10/11/24 02:05 AM
Symptom
- GlobalProtect (GP) client App on IOS (iPhone or iPad) throws an error message "The Internet connection appears to be offline".
- This happens when the connect method is set to On-Demand . (Only supported method when using SAML)
- On GP Portal, the authentication is set to "No (User Credentials AND Client Certificate Required)" which means both SAML and Certificate authentication is required.
- The GP app can connect without any issues if one of the auth method (Either only SAML or only Certificate) is used.
Environment
- GlobalProtect Client App on IOS (iPhone or iPad)
- Prisma Access for Mobile Users
- GlobalProtect on Strata NGFW.
Cause
- This happens when the MDM (Mobile Device Management) for the IOS is configured with an app rule for an identifier.
- The Agent.log file in GP support bundle logs shows following.
onDemandEnabled = YES
appRules = (
{
matchSigningIdentifier = com.paloaltonetworks.globalprotect.vpn
},
{
matchSigningIdentifier = com.esri.fieldmaps
},Resolution
- Work with the MDM team to remove the identifier configuration.
- For Microsoft Intune , the vpn setting should be none as shown below.
- Validate if the GlobalProtect portal configuration is matching following conditions.
- Default browser for SAML enabled & Connect method = 'On Demand' .
- GP client app is managed by qualified MDM.