Admin account locked after enabling password expiration
35281
Created On 11/10/20 13:11 PM - Last Modified 07/22/23 03:05 AM
Symptom
- Admin enable password expiration sometime after the admin accounts were created from Device > Password Profiles
- After enabling password expiration admins accounts are locked, in the logs can see that admins users are in locked users list.
Environment
- Palo Alto Firewall
- PAN-OS 9.1, 10.1, 10.2
- Password Profile
Cause
- Password expiry will be counted from the time account created or password changed, not from the time when policy is enabled.
- Let's say account was created 100 days ago and password was not changed since then. If password expiry will be enabled with 90 days period it will lock the account (default value).
- Admin passwords should be changed before enabling password expiration.
Resolution
Either revert your config or Factory reset from Maintenance Mode
How To Enter Maintenance Mode On Palo Alto Networks Firewall