Logs not visible after downgrading Panorama from 9.0.x to 8.x.x version
9014
Created On 06/25/19 21:16 PM - Last Modified 12/31/19 19:13 PM
Symptom
- All logs from 9.0.x version are not visible after downgrading Panorama to any PAN-OS versions prior to 9.0 versions.
Environment
- M-Series
- Panorama VMs
Cause
- The Elastic Search Engine version prior to PAN-OS 9.0 version is v2.2.
- The Elastic Search Engine version after PAN-OS 9.0 version is v5.6.
- The ES indices in v5.6 are different that ES indices of v.2.2.
- When upgrading to PAN-OS 9.0, the migration from v2.2 to v5.6 is done automatically.
- When downgrading from PAN-OS 9.0 to PAN-OS prior to 9.0, the migration from v5.6 to v2.2 must be done manually in order for logs to show up.
Resolution
- Migration command: >request logdb migrate lc serial-number <serial#> start
>request logdb migrate lc serial-number <serial-number> start Success. Migration Start Request sent to serial <serial-number>.
- To check the status of the migration: >>request logdb migrate lc serial-number <serial-number> status
>request logdb migrate lc serial-number <serial-number> status Slot: all Migration State: In Progress Percent Complete: 0.31 Estimated Time Remaining:35 hour(s) 7 min(s)
Additional Information
- As soon as the request logdb migrate lc serial-number <serial-number> start command is entered, the old logs will start showing up, and will not impact the new logs.
- Also, running this command will not impact the management functionalities such as creating/editing/pushing Template/Device Group