GlobalProtect Agent error Cannot connect to service, error: 10022

GlobalProtect Agent error Cannot connect to service, error: 10022

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Created On 08/31/19 12:51 PM - Last Modified 04/14/20 22:22 PM


Symptom


Global Protect not able to reach the portal and keeps connecting.
 

Logs from PANGP shows:

(T8796) 30/08/19 05:49:46:934 Error( 366): Cannot connect to service, error: 10022
(T8796) 30/08/19 05:49:51:934 Info ( 362): InitConnection ...
(T8796) 30/08/19 05:49:51:934 Error( 366): Cannot connect to service, error: 10022
(T8796) 30/08/19 05:49:56:934 Info ( 362): InitConnection ...
(T8796) 30/08/19 05:49:56:934 Error( 366): Cannot connect to service, error: 10022
(T8796) 30/08/19 05:49:57:934 Debug( 229): CPanSocket::onConnect - return error code = 10060.


Cause


This error means that the GP client can not communicate to the PanGPS process or the Pan agent is not able to start the PanGPS service in  the client machine itself.

Resolution


Make sure that the PanGPS is started and running in Task Manager --> Services
if needed you can reinstall the Agent which will confirm that the process is started automatically.

PanGPS service should be listening on localhost port 4767.  To check run the command on windows PC:

Netstat -an | find "4767"

the output should be as below for example:
 
TCP    127.0.0.1:4767          0.0.0.0:0                   LISTENING
  TCP    127.0.0.1:4767         127.0.0.1:49779        ESTABLISHED
  TCP    127.0.0.1:49779        127.0.0.1:4767         ESTABLISHED


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