GP App is not upgrading transparently when the portal setting "Allow User to Upgrade GlobalProtect" is already set to "Allow Transparently"; Portal and Gateways are on different firewalls
105059
Created On 09/26/18 13:49 PM - Last Modified 03/25/25 20:52 PM
Symptom
GP App is in the Connected state but is not upgrading transparently when the portal setting Allow User to Upgrade GlobalProtect is already set to Allow Transparently
Environment
- GlobalProtect (GP) App
- GP Portal
- GP Gateway
Cause
The Allow Transparent method only upgrades GP App when all of the following conditions are met:
- Portal status is Connected.
- GP App state is Connected (i.e. tunnel to the GP Gateway is established) and it automatically starts the upgrade process (i.e. we're not discussing the manual upgrade process where a user clicks the About > Check Update).
- Higher version of the GP App is activated on the GP Portal.
NOTE:
- If the portal status is Using cached portal config (i.e. GP App is Using cached portal config), none of the Allow User to Upgrade GlobalProtect settings would upgrade the GP App.
- The portal status must be Connected for any type of upgrades.