User-ID Agent error: "ldap connect failed: Strong Authentication Required"
Symptom
Error messages in UaCredDebug.log
06/23/25 13:37:57:946 [Error 1074]: pan_ldap_bind() failed
06/23/25 13:37:57:959 [Error 1892]: ldap connect failed: Strong Authentication Required
06/23/25 13:37:57:971 [Error 1701]: Failed to bind to LDAP server
06/23/25 13:38:08:135 [Error 542]: ldap_connect(user@DOMAIN.COM) return(8) : Strong Authentication Required
Note:
- UaCredDebug.log is found in the installation directory of the Credential Agent.
- By default, the installation directory is: C:\Program Files\Palo Alto Networks\User-ID Credential Agent
Environment
- User-ID Agent version 11.1.1 or newer
- User-ID Credential Service version 11.1.1 or newer
Cause
- This error indicates that the LDAP server rejected the connection attempt from the User-ID Agent.
- The rejection is because the server requires a more secure connection, such as LDAPS.
Resolution
- Enable the LDAPS on the Windows Server.
- Steps to to enable LDAPS on Windows Server are shown below.
- Open Server Manager (Start -> Server Manager).
- Go to Manage -> Add Roles and Features.
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In the “Add Roles and Features Wizard” window that opens, click “Next” on the initial screen.
- On the “Select installation type” screen, ensure this option is selected: “Role-based or feature-based installation”. Click “Next”
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On the “Select destination server” screen, ensure “Select a server from the server pool” is enabled, and the current server is selected. Click “Next”.
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On the “Select Server Roles” screen, select “Active Directory Certificate Services”.
- In the pop-up that opens, click “Add Features”.
- Click “Next”.
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On the “Active Directory Certificate Services”, click “Next”.
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On the “Select role services” screen, click “Next”.
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Optionally, enable “Restart the destination server automatically if required”. On the “Confirm installation selections” screen, click “Install”.
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After the installation completes, open Server Manager and select “Configure Active Directory Certificate Services on the destination server”.
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On the “Credentials” screen, you can choose to use the credentials of the current user or type different credentials. Click “Next”.
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On the “Role Services” screen, enable “Certificate Authority” and click “Next”.
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On the “Setup Type” screen, select “Enterprise CA” and click “Next”.
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On the “Ca Type” screen, select the option that is best for your use case and click “Next”.
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On the “Private Key” screen, select the option that is best for your use case and click “Next”.
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On the “Cryptography for CA” screen, select the option that is best for your use case and click “Next”.
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On the “CA Name” screen, configure the common name, distinguished name and distinguished name suffix for the CA and click “Next”.
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On the “Validity Period” screen, configure the desired validity and click “Next”.
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On the “CA Database” screen, configure the desired locations and click “Next”.
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On the “Confirmation” screen, validate the configuration and click “Configure”.
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Once the configuration completes, click “Close”.
Additional Information
- This article is written for informational purposes.
- The procedure may change when different patches/versions are installed on Windows.
- Palo Alto Networks does not support any third-party operating systems.