Prisma browser fails to update to the newer version

Prisma browser fails to update to the newer version

174
Created On 09/11/25 20:10 PM - Last Modified 12/10/25 02:18 AM


Symptom


  • Unable to Update/Upgrade the Prisma Access Browser.
  • Relaunching the browser does not help.


Environment


  • Prisma Browser
  • Windows 


Cause


The root certificates are NOT installed on Windows.



Resolution


Use the following steps to correct the issue [Windows Only]

 

  1. Make sure the system has all required root certificates installed 
    1. DigiCert {+}https://www.digicert.com/kb/digicert-root-certificates.htm+
    2. DigiCert Trusted Root G4 (notice there are a few; we require 05:9b)
    3. DigiCert Trusted G4 Code Signing (notice there are a few; we require 08:ad)
  2. Manually remove PAB files from:
      1. %PROGRAMFILES%\Palo Alto Networks\PrismaAccessBrowser
      2. %PROGRAMFILES(x86)%\Palo Alto Networks\Update
      3. %PROGRAMFILES(x86)%\Palo Alto Networks\Temp
      4. %PROGRAMFILES(x86)%\Palo Alto Networks\CrashReports
      5. %PROGRAMFILES%\Palo Alto Networks\PrismaAccessBrowserUpdater
  3. Now attempt to run the latest installer (get.pabrowser.com).
  4. Check If there is an active security product blocking the installation (Like GP/ other VPN or EDR that may block the installation).
  5. Only for update/upgrade issues: Make sure they don't have a "Delayed Release" or any other "Deployment upgrade" setting under Browser Customization rules.


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA1Ki000000kAFmKAM&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail