Prisma browser fails to update to the newer version
174
Created On 09/11/25 20:10 PM - Last Modified 12/10/25 02:18 AM
Symptom
- Unable to Update/Upgrade the Prisma Access Browser.
- Relaunching the browser does not help.
Environment
- Prisma Browser
- Windows
Cause
The root certificates are NOT installed on Windows.
Resolution
Use the following steps to correct the issue [Windows Only]
- Make sure the system has all required root certificates installed
- DigiCert {+}https://www.digicert.com/kb/digicert-root-certificates.htm+

- DigiCert Trusted Root G4 (notice there are a few; we require 05:9b)
- DigiCert Trusted G4 Code Signing (notice there are a few; we require 08:ad)
- DigiCert {+}https://www.digicert.com/kb/digicert-root-certificates.htm+
- Manually remove PAB files from:
-
-
%PROGRAMFILES%\Palo Alto Networks\PrismaAccessBrowser%PROGRAMFILES(x86)%\Palo Alto Networks\Update%PROGRAMFILES(x86)%\Palo Alto Networks\Temp%PROGRAMFILES(x86)%\Palo Alto Networks\CrashReports%PROGRAMFILES%\Palo Alto Networks\PrismaAccessBrowserUpdater
-
Now attempt to run the latest installer (get.pabrowser.com).- Check If there is an active security product blocking the installation (Like GP/ other VPN or EDR that may block the installation).
- Only for update/upgrade issues: Make sure they don't have a "Delayed Release" or any other "Deployment upgrade" setting under Browser Customization rules.