Prisma Browser does not show customized company logo and background image when connected with GlobalProtect
364
Created On 07/17/25 02:59 AM - Last Modified 12/08/25 22:54 PM
Symptom
- The company logo and background image are not updated in the Prisma Browser Customization when the GlobalProtect app is used on the system.
- The Prisma Browser troubleshooting (prisma://troubleshoot/) Diagnostics Static assets service display an error.
- If the GlobalProtect app is disabled and the PAB is connected directly via unrestricted internet, then the logo and background images do show up as expected.
Environment
- Prisma Browser
- GlobalProtect with Prisma Access or Strata Firewall
- SSL decryption
Cause
- The Prisma Browser connects to assets.talon-sec.com or one of the associated regional URLs based on the Prisma Browser region to fetch the logo and background image.
- For example, a tenant activated in Australia will connect to assets.au.talon-sec.com and a tenant in Singapore region will connect to assets.sg.talon-sec.com
- When using GlobalProtect and SSL decryption on the Prisma Access or upstream firewall, the decryption might fail for assets.talon-sec.com or assets.au.talon-sec.com which will cause this issue.
Resolution
- Add *.sg.talon-sec.com or *.au.talon-sec.com manually as a decryption exclusion to allow Prisma Browser to connect to assets.sg.talon-sec.com or assets.au.talon-sec.com
- Alternatively, Add *.*.talon-sec.com as a manual SSL exclusion which will match x.y.talon-sec.com and exclude the session from decryption.
- New content updates will add the *.*.talon-sec.com in global pre-defined SSL-decryption exclusion list.
Additional Information
- Although the article is about GlobalProtect, this would be application for any other 3rd party VPN client as well.
- The traffic to applicable domain (Example assets.sg.talon-sec.com) should not be subject to decryption.