After activating SaaS Inline license Panorama and Firewall WebUI experience an unresponsive page when accessing the Applications Objects
Symptom
• After activating SaaS Inline license (or CASB license) on Firewall, Panorama and Firewall WebUI experience an unresponsive page when accessing the Applications Objects
Environment
• Access the Panorama/Firewall WebUI from a computer with 8 GB of RAM (less than 16 GB)
• A lot of open tabs on the web browser while accessing the Applications page under Objects
Cause
• JavaScript in the browser runs on a single main thread
• Depending on the Host device resource, the client browser is taking time to load the Application page of 101K list
• A very large number of applications resulting from the new SaaS license are being requested and loaded into the browser memory. This is resulting in a performance impact on the web browser.
• Depending on the Client machine resource, min 30 seconds to max 90 to 120 seconds observed.
Resolution
1. Engineering has provided the following recommendations that have been tested in our lab:
- Access the Panorama/Firewall WebUI from a computer with at least 16 GB of RAM
- Maintain a good network connection
- Should have only one tab open on the web browser while accessing the Applications page, so that the browser memory would be fully occupied by the response
- It is better to remove additional unwanted plugins that utilize more memory of the browser
2. As a workaround, we can access the application objects through CLI Operations for both Panorama and Firewall
Additional Information
N/A