"unexpected status 409" error seen when deploying VM-Series Firewall from Terraform templates for Prisma AIRS

"unexpected status 409" error seen when deploying VM-Series Firewall from Terraform templates for Prisma AIRS

379
Created On 09/18/25 01:21 AM - Last Modified 02/24/26 21:24 PM


Symptom


  • When deploying VM-Series Firewall from Strata Cloud Manager for Prisma AIRS, the following error is seen when running 'terraform apply'
Error: creating/updating Virtual Machine (Subscription: "XXX"
Resource Group Name: "xxxxxxx-ai-runtime"
Virtual Machine Name: "xxxxxxxx-vm-01"): performing CreateOrUpdate: unexpected status 409 (409 Conflict) with error: SkuNotAvailable: The requested VM size for resource 'Following SKUs have failed for Capacity Restrictions: Standard_DS3_v2' is currently not available in location 'japaneast'. Please try another size or deploy to a different location or different zone. See https://aka.ms/azureskunotavailable for details.
  • Despite selecting Standard_D4_v3, the error still refers to Standard_DS3_v2, which suggests that the previous configuration may not have been fully cleared or updated.


Environment


  • AIRS AI Runtime
  • VM-Series Firewall on Azure
  • Terraform
  • Strata Cloud Manager


Cause


  • Azure does not support specific instances in specific regions
  • Terraform cache may remain even after changing the instance types in the templates


Resolution


  1. Adjusting the Strata Cloud Manager settings to Standard_D4_v3.
  2. Modifying the instance type to the same in the Terraform configuration.
  3. These changes will resolve the issue.


Additional Information


Deploy a VM-Series Firewall from Strata Cloud Manager



Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA1Ki000000fyBaKAI&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail