Prisma cloud - Conditions on which Alerts are deleted

Prisma cloud - Conditions on which Alerts are deleted

761
Created On 09/04/25 03:26 AM - Last Modified 02/05/26 18:30 PM


Symptom


Alerts not shown for older deleted resources.



Environment


Prisma cloud

  • Alerts
  • Cloud Accounts


Cause


Prisma cloud deletes alerts on the below scenarios .

1. Cloud account deletion - In case of account deletion, we delete alerts after 24 hours.

2. Resource hard deletion - Once the resource is marked as deleted, Prisma cloud resolve the alerts and Prisma cloud will delete the alerts only after 60 days

 

 



Resolution


Prisma cloud deletes older alerts if the resource is marked as deleted Prisma cloud will resolve the alert and delete the alert only after 60 days. 

Prisma cloud also deletes alerts related to an account in 24 hours when the cloud account is deleted from Prisma cloud.

  • Confirm Cloud account deletion
        • In Azure
          • Search for Account Name/ID under Subscriptions

      In Prisma Cloud (Providers)
      • Navigate to Settings > Providers 
      • Select Tenant
      • Search for Account Name/ID

        • In Prisma Cloud (Audit Logs)
          • Navigate to Settings > Audit Logs > Filter "Time Range": "Past 3 Months" and "Resource": "Cloud Account" "Cloud Account"
          • Search for Account Name/ID

     



    Additional Information


    The Alert removed from the Prisma Cloud database



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