La connexion avant ouverture de session ne fonctionne pas lorsque CAS est utilisé comme méthode d'authentification.
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Created On 07/24/25 10:04 AM - Last Modified 11/26/25 16:10 PM
Symptom
- Les utilisateurs de GlobalProtect reçoivent un écran blanc pendant la procédure CBL lorsqu'ils utilisent l'authentification CAS SAML.
- Il ne se passe rien avec le bouton « Cliquez ici » une fois l'authentification terminée.
Environment
- Pare-feu Palo Alto
- Pare-feu d'accès Prisma
- Application GlobalProtect (GP)
- Se connecter avant de se connecter (CBL)
- Authentification CAS SAML
Cause
- appli GP ne peut utiliser que le navigateur intégré pour CBL.
- CAS SAML exigeait un navigateur par défaut , ce qui n'est pas possible avec CBL.
Resolution
- CBL fonctionnera avec CAS intégré en définissant l'option cas-embedded-browser sur oui.
- Follow the steps below to enable the feature flag:
- Mettez à niveau PAN-OS pour utiliser la version 11.2.x ou une version supérieure.
- Mettez à jour appli GP pour utiliser la version 6.3.x ou une version supérieure.
- CAS embedded browser option needs to be enabled from firewall CLI to use CAS SAML with CBL embedded browser:
> set global-protect embedded-browser-cas enable [nothing returned if feature flag is already enabled]
> show global-protect embedded-browser-cas [Verify the feature flag is enabled]
NOTE: If it still does not work, loads Blank page, or gives script loading error, it might be due to the limitation of CBL using older webview