Conectarse antes de iniciar sesión no funciona cuando se utiliza CAS como método de autenticación
755
Created On 07/24/25 10:04 AM - Last Modified 11/26/25 16:10 PM
Symptom
- Los usuarios de GlobalProtect reciben una pantalla en blanco durante CBL cuando utilizan la autenticación CAS SAML.
- No ocurre nada con "Haga clic aquí" una vez completada la autenticación.
Environment
- Cortafuegos de Palo Alto
- Cortafuegos de acceso Prisma
- Aplicación GlobalProtect (GP)
- Conectarse antes de iniciar sesión (CBL)
- Autenticación CAS SAML
Cause
- La aplicación GP solo puede usar el explorador integrado para CBL.
- CAS SAML requiere un explorador valor predeterminado , lo que no es posible con CBL.
Resolution
- CBL funcionará con CAS integrado configurando la opción cas-embedded-browser en sí.
- Follow the steps below to enable the feature flag:
- Actualice PAN-OS para utilizar la versión 11.2.x o superior.
- Actualice la aplicación GP para usar la versión 6.3.x o superior.
- CAS embedded browser option needs to be enabled from firewall CLI to use CAS SAML with CBL embedded browser:
> set global-protect embedded-browser-cas enable [nothing returned if feature flag is already enabled]
> show global-protect embedded-browser-cas [Verify the feature flag is enabled]
NOTE: If it still does not work, loads Blank page, or gives script loading error, it might be due to the limitation of CBL using older webview