Prisma Cloud Compute: "Failure: Internal Server Error" while installing Jenkins Plugin
271
Created On 06/19/25 20:45 PM - Last Modified 06/23/25 18:46 PM
Symptom
- When trying to setup the Jenkins plugin using the Jenkins user interface, the user populates the Address, User, and Password field and then clicks on Test Connection to check if the credentials are okay to find the following error message:
Failure: Internal Server Error
Environment
- Jenkins (supported versions)
- Prisma Cloud SaaS Console (Enterprise edition)
- Prisma Cloud self-hosted Console (Compute edition)
Cause
- The above error occurs when an authentication attempt is made with credentials that are either invalid or have expired
- In this setup, Jenkins is the client and Prisma Cloud Console is the server and hence, using invalid credentials triggers a server-side internal server error
Resolution
Once valid credentials are used, the error disappears, and on clicking Test Connection, the status shows as OK.