Prisma Browser Internet Explorer (IE) Compatibility Mode does not display the site correctly, resulting in noticeably small display areas.

Prisma Browser Internet Explorer (IE) Compatibility Mode does not display the site correctly, resulting in noticeably small display areas.

1048
Created On 05/23/25 00:40 AM - Last Modified 12/08/25 22:30 PM


Symptom


  • In the end customer's Prisma Browser, the target site is configured to use IE Compatibility Mode. 
  • However, the site is not displayed correctly in IE mode.
     
  • The issue is consistently reproducible with internal legacy sites requiring Internet Explorer, as well as external sites.
  • The issue affects all users accessing IE compatibility-mode sites via Prisma Browser. 
  • Dragging the browser tab window restores the normal display. 
  • When accessing the same URL in Edge in IE mode (with IE mode configured), it is rendered correctly, utilizing the full window space.


Environment


• Prisma Browser 
• Prisma Access



Cause


Prisma Browser Internet Explorer Compatibility Mode currently has the following limitations:

  1. IE mode does not support any security controls.
  2. IE mode is not supported for private apps over Explicit Proxy (only GP).
  3. IE mode is currently only supported for an IE11-compatible website.


Resolution


  • Workaround: Dragging the target site's browser tab to resize it temporarily resolves the display issue. 
  • Be aware of the current limitations of the PAB product, and ensure that the customer environment meets the requirements as well.
  • As for the Prisma Browser Internet Explorer (IE) Compatibility Mode issue, the customer must make sure their site is an IE11-compatible website. 
    If it is not, work with the customer to support IE11 for the target site.


Additional Information




Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA1Ki000000fxbIKAQ&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail