When users try to renew an ADEM certificate on Panorama GUI, "Invalid Tenant ID" error is displayed and the renewal fails.
192
Created On 08/13/25 06:02 AM - Last Modified 11/13/25 00:06 AM
Symptom
- When users try to renew an ADEM certificate from the following navigation on Panorama GUI, "Invalid Tenant ID" error is displayed and the renewal fails.
Navigation: Panorama > Cloud Services > Configuration > Service Options > GlobalProtect App Log Collection and Autonomous DEM > Renew Certificate for GlobalProtect App Log Collection and Autonomous DEM - plugin_cloud_services.log displays correct tenant ID.
2025-08-01 17:43:27.510 +0900 INFO: [gpclient_cert] prisma access editions present are : ['LCL_MU_RN_ENT_2021_11_07.key'] 2025-08-01 17:43:27.510 +0900 INFO: [gpclient_cert] Serial number XXXXXXXXXX, for Tenant ID: XXXXXXXXXXXXXXXX 2025-08-01 17:43:27.516 +0900 INFO: [sdb] SDB cfg.csp-trusted-endpoint is empty 2025-08-01 17:43:27.605 +0900 INFO: [gpclient_cert] Generate CSR, result: True 2025-08-01 17:43:27.607 +0900 INFO: [sdb] SDB cfg.saas.g3-client-cert is empty 2025-08-01 17:43:27.612 +0900 INFO: [gpclient_cert] Setting curl params 1: 2025-08-01 17:43:27.612 +0900 INFO: [gpclient_cert] headers set are : '['Content-Type: application/json']' 2025-08-01 17:43:27.612 +0900 INFO: [gpclient_cert] Setting the certificate params 1: 2025-08-01 17:43:28.732 +0900 INFO: [gpclient_cert] b'{"status":"Error","cert":"","errormsg":"Invalid Tenant Id","randomkey":null}' 2025-08-01 17:43:28.732 +0900 INFO: [gpclient_cert] Curl result: 0
Environment
- Panorama Managed Prisma Access
- Panorama
- Cloud Services Plugin 5.0 or earlier
Cause
New Strata Logging Service related changes is after certain plugin version and not available in old version. It may cause the issue.
Resolution
Upgrade cloud services plugin to 5.1.0 latest hotfix version.