WildFire Error: "Unsupported File type for this license" when uploading JPG or PNG files
Symptom
-
Unable to manually upload JPG or PNG samples to WildFire.
-
Browser developer tools in Network --> Preview displays the error message "Unsupported File type for this license".
-
API submissions display the error "Unsupported File type for this license" in the HTTP response.
<?xml version="1.0" encoding="UTF-8"?>
<error>
<error-message>'Unsupported File type for this license'</error-message>
</error>
Environment
Advanced WildFire license
Cause
The API rejected JPG and PNG files because the customer's WildFire API key was initially provisioned with a regular WildFire license instead of an Advanced WildFire license, which is required for analyzing these file types.
The API Key type can be found on CSP --> WildFire --> WildFire API Keys --> Type: "WILDFIRE"
Resolution
Please contact Palo Alto Networks Support.
Additional Information
Advanced WildFire File Type Support