Existing users are unable to login via SSH

Existing users are unable to login via SSH

1160
Created On 05/06/25 07:33 AM - Last Modified 03/03/26 23:38 PM


Symptom


  • Existing users are unable to login via SSH
  • When using console, the configd.log indicates error in /etc/passwd.
> less mp-log configd.log
------------------
useradd: existing lock file /etc/passwd.lock with an invalid PID 'root:!'
useradd: cannot lock /etc/passwd; try again later.
usermod: user '________' does not exist


Environment


  • Next-Gen Firewalls or Panorama
  • PAN-OS 10.x and 11.x


Cause


System lock files in /etc directory blocking authentication.



Resolution


  1. A new CLI command has been introduced under PAN-230893 listed below.
> delete authentication system-lock-files
  1. The command is available in the PAN-OS versions 10.1.16, 10.2.11, 11.0.7, 11.1.5, 11.2.4, 11.1.4-h6, 12.1.0 and higher.
  2. Run the command to delete all the lock files.
  3. If the issue is not resolved after running the command, open a support case.


Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA1Ki000000blPHKAY&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail