GlobalProtect app is unable to connect to Prisma Access Internal Gateway with the error "No such host is known"
1870
Created On 04/18/25 01:57 AM - Last Modified 10/16/25 21:44 PM
Symptom
This is an explanation of connection failure to the Prisma Access Internal Gateway. Please check if the following two conditions match your situation.
- GlobalProtect app is unable to connect to the Internal Gateway with the environment the Internal Host Detection is disabled.
- There is the following error in PanGPS.log of Global Protect app log.
Note: The "abcde12345" is actually the customer dependent characters.(P1234-T5678)Error( 456): 07/03/25 01:01:54:464 getaddrinfo for fqdn any-igw.abcde12345.gw.gpcloudservice.com failed, 0. (P1234-T5678)Debug( 789): 07/03/25 01:01:54:464 getaddrinfo of any-igw.abcde12345.gw.gpcloudservice.com failed with error 11001, No such host is known.
Environment
- Prisma Access Internal Gateway
- Global Protect
- Internal Host Detection is disabled
Cause
It is the expected behavior when enabling Internal Gateway but disabling Internal Host Detection.
Resolution
Enable name resolution of Internal Gateway in the customer environment. to resolve the last IP of the Infrastructure subnet.
Example: If the Infrastructure subnet is 10.135.0.0/23, then the last IP is 10.135.1.254.
Either of the following two is fine.
- Adding an A record for "any-igw.[customer dependent characters].gw.gpcloudservice.com" to the customer's DNS server.
- (When it is difficult to do 1. such as during verification) Adding the resolved IP address to resolve to and the FQDN "any-igw.[customer dependent characters].gw.gpcloudservice.com" to the client's static hosts file.