GlobalProtect is redirecting user to default browser but SAML Login page opens in Edge while the Default App for web-browsing is set to Chrome
Symptom
• GlobalProtect client consistently uses MS Edge for SAML authentication, despite Chrome being set as the default browser.
• Any HTML file's properties show the legacy IE as the default app
Environment
GP App
PAN-OS
Windows OS 11
Cause
Windows 11 system policies or permissions are preventing the user account from changing the default application for HTML files (.html and .htm). The C:\Users\<username>\AppData\Local\Temp\saml.html page is associated with legacy Internet Explorer (IE), and this association cannot be changed to Chrome by the end-user due to OS policy restrictions
Resolution
Make sure the Default App for .html content is set to Chrome under Windows OS 11 > Settings > Apps > Default Apps > Google Chrome
OR
Right-click on the C:\Users\<username>\AppData\Local\Temp\saml.html (SAML Redirect HTML) file to open Properties. Click the Change button, select Chrome, and Set Default App
NOTE: If an end-user still does not see the .html type under Default App OR the Change button under properties, please check with the IT team, as it's not a GlobalProtect issue; it's Windows OS 11 permissions and policies restrictions on the end-user
Additional Information
N/A