GlobalProtect App fails to connect to the GlobalProtect Portal when using Windows 365 and SAML authentication via the embedded browser
1024
Created On 07/30/25 07:34 AM - Last Modified 09/29/25 23:23 PM
Symptom
- The GlobalProtect App fails to connect to the GlobalProtect Portal when using Windows 365 and SAML authentication via the embedded browser
- GP App displays "Connecting... You are redirected to an embedded browser to authenticate and connect"
- Thereafter no message appears and displays "Not Connected"
- the GP client just shows, but nothing actually happens and then it shows "Not Connected".
Then -
Environment
- SAML authentication
- Embedded browser
- GlobalProtect App 6.2.8
- Windows 365
Cause
- The embedded browser did not receive the response from IDP within 30 sec of timeout.
- This is displayed in the PanGPA.log by the log message "webview2 callback timeout".
11:31:11:479 CPanSAMLView: clear autofill
11:31:11:479 CPanSAMLView: clear server certificateerroractions
11:31:11:527 ClearServerCertificateErrorActions Error 0
11:31:11:529 NavigationStarting URL https://login.microsoftonline.com/9f8ff257-76bc-46c6-8b06-18664d42a197/saml2?SAMLRequest=xxxxxx
11:31:12:426 CPanSAMLView: Browser Process Exited
11:31:33:003 Display the main panel when user click the tray icon.
11:31:33:010 Show the main panel.
11:31:41:482 CPanSAMLView::OnTimer webview2 callback timeout. Resolution
- Update the webview2 call back timeout registry to a value larger than 30s.
- This is done by adding a new key in the registry of Windows.
- Once the registry key is added, Restart the PanGPS service
- The key is added under:
HKEY_LOCAL_MACHINE\SOFTWARE\Palo Alto Networks\GlobalProtect\Settings
-
- keyname : webview2-timeout
- type: string
- Value: 60 (meaning 1 minute, can be longer)