In SCM if the group name in the security policy is in Japanese, some group name display will be garbled
Symptom
The customer is using Entra ID→ CIE to do group mapping for prisma access.
In CIE customer can see that the group name in Japanese is displayed okay.
However, in SCM if the group name in the security policy is in Japanese, some group name display will be garbled showing as ‘xxxx_____________’.
Environment
- EntraID, CIE, Prisma Access (SCM)
Cause
For Azure AD (EntraID), CIE uses "mailNickname" to compose group's CN/DN. But "mailNickname" only supports ASCII (https://learn.microsoft.com/en-us/graph/api/resources/group?view=graph-rest-1.0).
Resolution
To resolve this issue, we need to change AAD group attribute mapping.
First change it to make it like this.
Restore the Name attribute to default.
Finally, it should be like this.
After that, select "Actions" and "Full Sync". This should address this malformed CN/DN issue seen in both CIE and SCM UI.