GlobalProtect restarts repeatedly after upgrading GlobalProtect App.

GlobalProtect restarts repeatedly after upgrading GlobalProtect App.

2686
Created On 05/01/25 08:18 AM - Last Modified 05/16/25 20:23 PM


Symptom


  • Upgrading GlobalProtect App to version 6.2.3 or later causes the App to restart repeatedly.
  • The Use Default Browser for SAML Authentication option is set to No. It is located below.
    Network > GlobalProtect > Portals > <portal-config> > Agent <agent-config> > App > Use Default Browser for SAML Authentication
  • In PanGPA.log, the following logs can be observed.
    (P18364-T17452)Dump (1373): 04/25/25 13:54:22:929 CPanSAMLView: GetInstallPathFromDisk c:\Program Files (x86)\Microsoft\EdgeWebView\Application\100.0.1185.36
    (P18364-T17452)Debug(1255): 04/25/25 13:54:22:929 CPanSAMLView:: Install Path c:\Program Files (x86)\Microsoft\EdgeWebView\Application\100.0.1185.36
    (P18364-T17452)Debug( 108): 04/25/25 13:54:22:929 get install path c:\Program Files (x86)\Microsoft\EdgeWebView\Application\100.0.1185.36
    (P18364-T17452)Dump (1278): 04/25/25 13:54:22:929 CPanSAMLView: (SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft EdgeWebView) does not exist
    (P18364-T17452)Dump (1321): 04/25/25 13:54:22:929 CPanSAMLView: InstallLocation Not Found


Environment


  • GlobalProtect App version 6.2.3 or higher
  • Microsoft Windows
  • SAML authentication


Cause


  • In GlobalProtect version 6.2.3, the embedded browser framework has been upgraded to use WebView2.
  • The corresponding Microsoft Edge WebView version is old or WebView2 version is not installed properly.


Resolution


  1. Install the latest Microsoft Edge WebView2. 
  2. The workaround is to Change the Default Browser for SAML Authentication.


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    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA1Ki000000TN8GKAW&lang=en_US&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail