GlobalProtect status on Android devices is displaying incorrectly
1015
Created On 04/29/25 00:46 AM - Last Modified 03/07/26 04:47 AM
Symptom
- Android devices managed via MDM display an incorrect GlobalProtect connection status.
- Status fields remain blank even when the device is successfully connected to the VPN Gateway.
Environment
- Global Protect App
- Android Mobile Device Management (MDM)
Cause
- The 'headless_mode', activated via MDM configuration is preventing the GlobalProtect app from updating its UI.
- This is leading to the blank status display.
Resolution
- Disable the headless mode from app configuration.
- The key headless_mode need to be turned off in MDM settings.