Autonomous Digital Experience Management (ADEM) エージェントが「サブテナント ID の取得中にエラーが発生しました」というエラーで接続できません
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Created On 08/02/24 03:57 AM - Last Modified 12/05/25 21:13 PM
Symptom
- Autonomous Digital Experience Management (ADEM) は GlobalProtect 側で正しく構成され、有効になっていますが、Strata Cloud マネージャーにはエクスペリエンスに関する利用可能なデータがありません。
- The Agent logs palo_alto_networks_dem_update_service.log を参照してください" shows following errors.
[date-time INFO] Start updating agent. [date-time WARN] No subtenant-id found... [date-time EROR] Error occurred getting subtenant-id. System.Security.Cryptography.CryptographicException: Cryptography_InvalidPadding at Internal.Cryptography.UniversalCryptoDecryptor.GetPaddingLength(ReadOnlySpan`1 ) - - - - [date-time EROR] Error occurred getting subtenant-id. - この問題は Windows にのみ適用されます。
- GlobalProtect ログ ファイル バンドルには、 palo_alto_networks_dem_agent.logおよびpalo_alto_networks_dem_service.logログ ファイルが含まれません。(これらのログ ファイルが欠落しているということは、DEM がサービスを開始して機能させることができていないことを示しています)
Environment
- モバイル ユーザー向けの Prisma Access。
- Autonomous Digital Experience Management エージェント バージョン 5.3 以下。
- Windowsのみ。
Cause
- ADEM エージェントは更新するプロセスを開始し、設定をダウンロードするために Prisma Access バックエンドに接続するための Prisma Access テナント ID を計算する必要があります。
- エージェントは、プロセスの一部としてWMIC Windows ユーティリティを使用してデバイスのシリアル番号を取得します。
- Windows システムで WMIC が有効化/許可されていない場合、または BIOS シリアル番号がNULL (未設定) の場合、テナント ID を計算するプロセスは失敗し、ログに上記のエラーが表示されます。
- これにより、エージェントは接続できなくなります。
Resolution
- この問題を解決するには、WMIC を実行し許可。そのためには、ローカル IT チームと連携してください。
- すべてのプロセスに対してWMICを許可することに他の懸念がある場合は、プロセスDEMUpdateService.exeに対してのみ許可。
- Prisma Access は、代替アプローチを使用し、wmic 依存関係を削除する ADEM エージェントの新しいバージョンをリリースします。
- シリアル番号が BIOS に設定されていることを確認します。
Additional Information
この問題が発生しているかどうかを確認するには、Windows Powershell で次のコマンドを実行しますが、失敗します (管理者権限なし)
wmic bios get serialnumber
「 wmic 」が利用できない場合の結果。
BIOS にシリアル番号が設定されていないが、wmis ic が使用可能な場合の結果。