Der Autonomous Digital Experience Management (ADEM)-Agent stellt keine Verbindung mit dem Fehler „Beim Abrufen der Subtenant-ID ist ein Fehler aufgetreten“ her.

Der Autonomous Digital Experience Management (ADEM)-Agent stellt keine Verbindung mit dem Fehler „Beim Abrufen der Subtenant-ID ist ein Fehler aufgetreten“ her.

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Created On 08/02/24 03:57 AM - Last Modified 12/05/25 21:13 PM


Symptom


  • Autonomous Digital Experience Management (ADEM) ist auf der GlobalProtect-Seite korrekt konfiguriert und aktiviert, aber im Strata Cloud Manager sind keine Daten zur Erfahrung verfügbar.
  • The Agent logs "palo_alto_networks_dem_update_service.log" shows following errors.
    [date-time INFO] Start updating agent.
    [date-time WARN] No subtenant-id found...
    [date-time EROR] Error occurred getting subtenant-id.
    System.Security.Cryptography.CryptographicException: Cryptography_InvalidPadding
       at Internal.Cryptography.UniversalCryptoDecryptor.GetPaddingLength(ReadOnlySpan`1 )
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    [date-time EROR] Error occurred getting subtenant-id.
    
    
  • Dieses Problem tritt nur unter Windows auf.
  • Das GlobalProtect-Protokolldateipaket enthält nicht die Protokolldateien palo_alto_networks_dem_agent.log und palo_alto_networks_dem_service.log . (Diese fehlenden Protokolldateien weisen darauf hin, dass DEM die Dienste nicht starten konnte.)



Environment


  • Prisma Access für mobile Benutzer.
  • Autonomous Digital Experience Management-Agent, Version 5.3 oder niedriger.
  • Nur Windows.


Cause


  • Der ADEM-Agent startet einen aktualisieren und muss die Prisma Access-Mandanten-ID berechnen, um eine Verbindung zum Prisma Access-Backend herzustellen und die Konfiguration herunterzuladen.
  • Der Agent verwendet im Rahmen des Prozesses das Windows-Dienstprogramm WMIC , um die Seriennummer des Gerät abzurufen.
  • Wenn WMIC auf dem Windows-System nicht aktiviert/zugelassen ist oder die BIOS-Seriennummer NULL (nicht festgelegt) ist, schlägt der Vorgang zum Berechnen der Mandanten-ID fehl und in den Protokollen wird der oben angegebene Fehler angezeigt.
  • Dies führt dazu, dass der Agent keine Verbindung herstellen kann.


Resolution


  1. zulassen WMIC laufen, um dieses Problem zu beheben. Arbeiten Sie dazu mit Ihrem lokalen IT-Team zusammen.
  2. Wenn es weitere Bedenken hinsichtlich der Zulassung von WMIC für alle Prozesse gibt, zulassen es nur für den Prozess DEMUpdateService.exe zu.
  3. Prisma Access wird eine neue Version des ADEM-Agenten veröffentlichen, die einen alternativen Ansatz verwendet und die WMIC-Abhängigkeit entfernt.
  4. Stellen Sie sicher, dass die Seriennummer im BIOS eingestellt ist.


Additional Information


Um zu bestätigen, dass Sie auf dieses Problem stoßen, führen Sie den folgenden Befehl in Windows Powershell aus, der fehlschlägt (ohne Administratorrechte).

wmic bios get serialnumber

Ergebnis, wenn „ wmic “ nicht verfügbar ist.
Wmic-Befehlsfehler

Ergebnis, wenn die Seriennummer im BIOS nicht festgelegt wurde, aber WMI-IC verfügbar ist. wmic ist verfügbar, aber die Seriennummer ist nicht festgelegt



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