L'authentification SAML avec Cloud Identity Engine (CIE) échoue avec le message « Incompatibilité d'ID CSP » dans les journaux système

L'authentification SAML avec Cloud Identity Engine (CIE) échoue avec le message « Incompatibilité d'ID CSP » dans les journaux système

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Created On 06/12/24 01:40 AM - Last Modified 01/03/25 03:56 AM


Symptom


  • Le profil d’authentification est configuré pour utiliser Cloud Identity Engine (CIE) comme fournisseur SAML.
  • L'authentification du client échoue avec le message suivant dans le journal système ( show log system ) et authd.log.
Failed to parse CAS token from client 'xxx.xxx.xxx.xxx' from 'https://cloud-auth.jp.apps.paloaltonetworks.com/auth' with auth_session_id 
'********-****-****-****-************' : CSP ID mismatch (received AAA vs on-device BBB) for CAS profile "********-****-****-****-************" ;
tenant "<TENANT_ID>" ; region "<REGION>" ; username "<USERNAME>"




Environment


  • Pare-feu de nouvelle génération Palo Alto (NGFW)
  • Cloud Identity Engine (CIE) est activé
  • Pare-feu utilisant CIE comme fournisseur d'authentification SAML


Cause


Comme indiqué dans le message d'erreur, l'ID CSP associant CIE ( AAA dans l'exemple de message de journal ci-dessus) et l'ID CSP mis en cache localement par le processus authd ( BBB dans l'exemple de message de journal ci-dessus) sont différents.



Resolution


Ce problème peut être résolu en redémarrant le processus authd avec la commande CLI suivante :

> debug software restart process authd



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