GlobalProtect connections fails with "Assign Private IP address failed" in the system logs.

GlobalProtect connections fails with "Assign Private IP address failed" in the system logs.

13540
Created On 10/10/22 06:49 AM - Last Modified 10/17/24 09:49 AM


Symptom


GlobalProtect connections fails with "Assign Private IP address failed" message in the system logs.

Environment


Remote users connecting to company network using GlobalProtect.



Cause


IP pool exhaustion can cause this issue and below rasmgr.log entry can be seen during the issue:
2021-08-05 22:08:06.868 -0700 Error: _find_free_ip_internal(src/ippool.c:153): ip pool#0 exit! loopcount(1) curpool(0) startpool(0) endip (10.0.x.x) nextip (10.0.x.x) whole loop finished, failed to find ip
2021-08-05 22:08:06.868 -0700 Error: rasmgr_sslvpn_client_config(src/rasmgr_sslvpn.c:2594): sslvpn_allocate_ip failed!


Resolution


Increasing existing IP pool or additional IP pool can resolve the issue and result in complete GlobalProtect connection.

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