Defender に接続できませんPrisma Cloudコンソールに「ホスト名の競合により接続に失敗しました」というエラーが表示される
Symptom
Defender に接続できませんPrisma CloudDefender ログに次のエラー メッセージが表示されたコンソール:
Connection failed due to hostname conflict, Defender name "<hostname>" is already connected.
Environment
- Prisma Cloud
Cause
- インストール中に、Defender は基になるホストからホスト名を Defender として取得します。ID .
- Prisma Cloud コンソールにはディフェンダーが必要ですIDユニークであること。
- 一意でない場合、同じ Defender を持つ別のホストによる後続の接続ID(ホスト名) は拒否されます。
Resolution
以下は、次のフラグを使用して Defender を再インストールするためのさまざまな展開シナリオの手順です: unique_hostname=true
オーケストレーター (デーモンセット):
- Kubernetes や Openshift などのオーケストレーターを使用すると、単純に変更できます。YAML /Helm Chart 以下のように、クラスターに再度適用します。
- Orchestrator は、新しい構成でノード全体に防御ポッドを自動的に再デプロイします。
あなたが持っている場合YAML/HELM展開に使用された手順は次のとおりです。
YAML
- テキスト エディターで yaml ファイルを開き、CLOUD_HOSTNAME_ENABLED という名前のキーを見つけて、値を false から true に変更します。
キー CLOUD_HOSTNAME_ENABLED が見つからない場合は、次の図のように新しいキー/値を作成します。
- コマンドを実行して、daemonset の新しい設定をプッシュします。
kubectl apply -f example.yaml
注: example.yaml を、使用している yaml ファイル名に置き換えます。
4.デーモンセットを更新した後、クラスターは既存のポッドを自動的に削除し、一意のホスト名/防御者を持つ新しい設定でポッドをデプロイしますID.
ヘルム チャート
twistlock defer Helm チャートのパスにある value.yaml を開き、name でキーの値を変更します。 unique_hostname 、 から間違いに真実
キーが見つからない場合は、下の図のように新しいキー/値を作成しますunique_hostname :
コマンドを実行して、ヘルム経由でデーモンセットの新しい設定をプッシュします。
ヘルムのアップグレード -n ツイストロック ツイストロック
(注: 名前空間や helm リリース名を twistlock から独自に定義した名前に変更する必要がある場合があります)
出力例:
オリジナルが見つからないYAML/ヘルムチャート?
見つからない場合はYAML/HELMディフェンダーの配備に使用されたチャートを使用して、新しいチャートを生成できますYAML/HELM以下の手順で:
に行くコンピューティングUI> 管理 > Defender > 導入 > Defender > Orchestrator .
オーケストレーターの種類、Defender 通信ポートなど、環境に最適なオプション/値を選択してください。
「グローバルに一意の名前をホストに割り当てる (オプション)」が「オン」になっていることを確認します。
すべてのオプションが適切に選択されていることを確認したら、[ダウンロード] をクリックします。YAMLまたはそれに応じて Helm チャート:
シングルディフェンダー:
シングル ディフェンダーを使用している場合は、現在のディフェンダーをアンインストールしてから、次の手順で新しいディフェンダーをインストールする必要があります。
ディフェンダーをアンインストールします。
ウィンドウズ:
admin を使用して、コマンド プロンプトで次のコマンドを実行します。
C:\プログラムファイル\Prisma Cloud \scripts\defender.ps1 -アンインストール
OR
C:\Program Files\Twistlock\scripts\defender.ps1 -アンインストール
Linux - コンテナ ディフェンダー:
次のコマンドを実行します。
sudo /var/lib/twistlock/scripts/twistlock.sh -u
Linux - ホスト ディフェンダー:
次のコマンドを実行します。
sudo /var/lib/twistlock/scripts/twistlock.sh -u 防御サーバー
Defender を再インストールします。
コンピューティングにアクセスUI> 管理 > 防御者 > 展開 > 防御者 > 単一の防御者
Defender のタイプ、Defender の通信ポートなどを選択するなど、環境に最適なオプション/値を選択してください。
「グローバルに一意の名前をホストに割り当てる (オプション)」が「オン」になっていることを確認します。
最後の手順でスクリプトをコピーし、ホストで実行して新しい防御側をインストールします。
Linux の場合、結果を terminal/ に貼り付けます。CLI
Windows の場合、結果を powershell に貼り付けます
新規インストール後、Defender は一意のホスト名を使用してコンソールに報告する必要があります。 問題が解決しました。