Defender no puede conectarse a la consola con el error "Error de conexión debido a un Prisma Cloud conflicto de nombre de host"

Defender no puede conectarse a la consola con el error "Error de conexión debido a un Prisma Cloud conflicto de nombre de host"

21023
Created On 08/15/22 15:23 PM - Last Modified 03/02/23 03:58 AM


Symptom


Defender no puede conectarse a la Prisma Cloud consola con el siguiente mensaje de error visto en Defender Logs:
Connection failed due to hostname conflict, Defender name "<hostname>" is already connected.


Environment


  • Prisma Cloud


Cause


  • Durante la instalación, Defender tomará el nombre de host del host subyacente como el Defender ID.
  • Prisma Cloud La consola requiere que el Defender ID sea único.
  • Si no es única, la conexión posterior de otro Host con el mismo Defender ID (Nombre de host) será rechazada.


Resolution


  • A continuación se indican los pasos enumerados para diferentes escenarios de implementación para volver a instalar el Defender con el indicador: unique_hostname=true

Orquestador(daemonset):

  • Con cualquier orquestador como Kubernetes u Openshift, simplemente puede modificar el YAMLgráfico /Helm como se muestra a continuación y aplicarlo nuevamente al clúster.
  • Orchestrator volverá a implementar los pods de defensor en los nodos con una nueva configuración automáticamente.

Si tiene YAML/HELM que se usó para la implementación, estos son los pasos:


YAML
 

  1. Abra el archivo yaml con el editor de texto, busque una clave con el nombre CLOUD_HOSTNAME_ENABLED y modifique el valor de false a true
  2. Cree una nueva clave/valor como se muestra a continuación cuando no pueda encontrar la clave CLOUD_HOSTNAME_ENABLED:

    Captura de pantalla 2022-08-15 a las 10.46.36 PM.png

  3. Ejecute el comando para insertar la nueva configuración del daemonset:

kubectl apply -f ejemplo.yaml

Nota: Reemplace example.yaml por el nombre de archivo yaml que está utilizando.

4. Después de actualizar el daemonset, el clúster eliminará automáticamente los pods existentes e implementará pods con nuevas configuraciones que tienen un nombre de host / defensor IDúnico.


Gráfico de timón
 

  1. Abra value.yaml en la ruta de trazado del defensor twistlock Helm chart y modifique el valor de la clave con el nombre unique_hostname, de false a true

  2. Cree una nueva clave/valor como se muestra a continuación, cuando no pueda encontrar la clave unique_hostname:

Captura de pantalla 2022-08-15 a las 11.00.32 PM.png

  1. Ejecute el comando para empujar la nueva configuración del daemonset a través del timón:
     

    Helm Upgrade -n Twistlock Twistlock

    (Nota: Es posible que deba cambiar el espacio de nombres y/o el nombre de la versión de timón de twistlock a su propio nombre definido)
    Ejemplo de salida:

Captura de pantalla 2022-08-15 a las 11.03.52 PM.png


¿No encuentras el /Helm Chart original YAML?
 

  • Si no puede encontrar el gráfico / que se utilizó para implementar el YAMLdefensor, puede generar un nuevo YAML/HELMHELM con los siguientes pasos:

  1. Vaya a Compute UI > Manage > Defenders > Deploy > Defenders > Orchestrator.

  2. Seleccione la mejor opción/valor que se adapte a su entorno, como elegir el tipo de orquestador, el puerto de comunicación de Defender... etc.

  3. Asegúrese de que "Asignar nombres únicos globales a hosts (opcional)" está "Activado":

Captura de pantalla 2022-08-14 a las 4.44.05 PM.png

  1. Después de confirmar que todas las opciones están bien elegidas, haga clic en descargar YAML o Helm chart en consecuencia:

Captura de pantalla 2022-08-15 a las 11.08.38 PM.png


Defensor único:
 

  • Si está utilizando Single Defender, deberá desinstalar el defensor actual y, a continuación, instalar un nuevo defensor con los siguientes pasos:

  1. Desinstalar el defensor:

  • Windows:

    • Ejecute este cmd en el símbolo del sistema con admin:

C:\Archivos de programa\\scripts\Prisma Clouddefender.ps1 -uninstall

          OR

C:\Archivos de programa\Twistlock\scripts\defender.ps1 -uninstall

  • Linux - Container Defender:

    • Ejecute este cmd:

      sudo /var/lib/twistlock/scripts/twistlock.sh -u

  • Linux - Host Defender:

    • Ejecute este cmd:

sudo /var/lib/twistlock/scripts/twistlock.sh -u defender-server

  1. Vuelva a instalar el Defender:

    1. Visite Compute UI > administrar > Defenders > implementar > Defenders > Single Defender

    2. Seleccione la mejor opción/valor que se adapte a su entorno, como elegir el tipo de Defender, el puerto de comunicación de Defender... etc.

    3. Asegúrese de que "Asignar nombres únicos globales a hosts (opcional)" está "Activado"

Captura de pantalla 2022-08-15 a las 11.19.07 PM.png

  1. Copie el script en el último paso y ejecútelo en su host para instalar un nuevo defensor.

    • Para Linux, pegue el resultado en el terminal /CLI

    • Para Windows, pegue el resultado en PowerShell

  2. Después de la nueva instalación, el defensor debe usar un nombre de host único para informar a la consola. Problema resuelto.



Additional Information


Ruta de registro:
 


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