La aplicación GlobalProtect no puede acceder al certificado del cliente en Android cuando el teléfono está bloqueado

La aplicación GlobalProtect no puede acceder al certificado del cliente en Android cuando el teléfono está bloqueado

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Created On 07/19/22 12:28 PM - Last Modified 01/07/25 15:40 PM


Symptom


  • La aplicación GlobalProtect no puede conectarse al portal/puerta de enlace si se requiere autenticación del certificado del cliente y el teléfono/la pantalla están bloqueados en el momento de la conexión.
  • Los registros del cliente GP muestran los siguientes registros.
:440596 - PanKeyManager: getPrivateKey for alias: User 4911aa55-0aa1-4cc1-9669-12344456d789
:520492 - PanKeyManager: key is not found for alias: User 4911aa55-0aa1-4cc1-9669-12344456d789
  • Visualización de registros de SamsungKnow

keystore: !@ LockedByCCM"
W System.err: java.security.UnrecoverableKeyException: Failed to obtain information about key


Environment


  • Aplicación GlobalProtect para Android
  • Certificados implementados a través de MDM.
Nota: Es más probable que el problema ocurra con una conexión siempre activa, ya que el restablecimiento puede ser activado por la propia aplicación ).


Cause


GP no puede acceder a la clave privada del certificado, necesaria para el proceso de autenticación, ya que el acceso está bloqueado por CCM (Administración de certificados de cliente).

Resolution


  1. Eximir " com.paloaltonetworks.globalprotect " de las políticas de CCM (Administración de certificados de cliente) en MDM (Administración de dispositivos móviles).
  2. Esto permitirá a GP acceder a la clave privada del certificado y conectarse sin que el teléfono esté desbloqueado.


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