PanGPS service does not start after system reboot
42100
Created On 07/15/22 01:44 AM - Last Modified 08/16/24 01:23 AM
Symptom
- Connect Button on GlobalProtect (GP) agent does not work after restart.
- The GP agent is showing error "Could not connect to GlobalProtect service. Make sure the GlobalProtect service is running."
- System event logs from computer indicates that the PanGPS service failed to start along with timeout reached.
Environment
- Windows OS
- Globalprotect Agent
Cause
Cause 1:
- By default Service Control Manager waits for 30,000 milliseconds (30 seconds) for a service to respond during bootup.
- If the PanGPS service does not respond within the configured timeout error message is displayed.
Cause 2:
The PanGPS service needs some dependent services to start properly, and those dependent services need to be set to startup automatically.
Resolution
Resolution for cause 1:
- Open the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.
- Configure DWORD registry value ServicesPipeTimeout to 60000 (60 seconds) or higher value 180000 (180 seconds).
- With this timeout increase service will not timeout as it gets sufficient time to respond. Refer Microsoft documentation for details.
- Press Win + R, type services.msc, and press Enter.
- Locate the PanGPS service.
- Right-click on PanGPS and select Properties.
- Ensure that the Startup type is set to Automatic.
- Go to the Dependencies tab and ensure that all dependent services are also set to start automatically:
Windows Management Instrumentation
Remote Procedure Call (RPC)
DCOM Server Process Launcher
RPC Endpoint Mapper
Additional Information
How to Reset and Re-register Windows Management Instrumentation (WMI)