系统重启后 PanGPS 服务未启动

系统重启后 PanGPS 服务未启动

42248
Created On 07/15/22 01:44 AM - Last Modified 01/07/25 13:31 PM


Symptom


  • 重启后,GlobalProtect (GP) 代理上的连接按钮不起作用。
  • GP 代理显示错误“无法连接到 GlobalProtect 服务。请确保 GlobalProtect 服务正在运行。”
  • 计算机的系统事件日志表明 PanGPS 服务启动失败且已超时。
System event from PC


Environment


  • Windows 操作系统
  • Globalprotect 代理


Cause


原因 1:
  • 默认下,服务控制管理器在启动期间等待 30,000 毫秒(30 秒)以等待服务响应。
  • 如果 PanGPS 服务在配置的超时内没有响应,则会显示错误消息。
注意:延迟可能是由于补丁升级或任何其他原因。

原因 2:
PanGPS 服务需要一些依赖服务才能正常启动,并且这些依赖服务需要设置为自动启动。
图片.png


Resolution


原因 1 的解决方法:
  1. 打开注册表HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control。
  2. 将 DWORD 注册表值ServicesPipeTimeout配置为 60000(60 秒)或更高值 180000(180 秒)。
  3. 增加超时后,服务将不会超时,因为它有足够的时间来响应。有关详细信息,请参阅Microsoft 文档
原因 2 的解决方法:
  1. 按 Win + R,输入 services.msc,然后按 Enter。
  2. 找到 PanGPS 服务。
  3. 右键单击“PanGPS”并选择“属性”。
  4. 确保启动类型设置为自动。
  5. 转到“依赖项”选项卡并确保所有依赖服务也设置为自动启动:
    Windows 管理规范
    远程过程调用(RPC)
    DCOM 服务器进程启动器
    RPC端点映射器


Additional Information


如何重置并重新注册 Windows 管理规范 (WMI)

Actions
  • Print
  • Copy Link

    https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA14u000000wkzQCAQ&lang=zh_CN&refURL=http%3A%2F%2Fknowledgebase.paloaltonetworks.com%2FKCSArticleDetail

Choose Language