시스템 재부팅 후 PanGPS 서비스가 시작되지 않습니다.
42152
Created On 07/15/22 01:44 AM - Last Modified 01/07/25 13:33 PM
Symptom
- GlobalProtect(GP) 에이전트의 연결 버튼이 재시작 후 작동하지 않습니다.
- GP 에이전트가 "GlobalProtect 서비스에 연결할 수 없습니다. GlobalProtect 서비스가 실행 중인지 확인하세요."라는 오류를 표시합니다.
- 컴퓨터의 시스템 이벤트 로그에 PanGPS 서비스가 타임아웃 로 인해 시작되지 않았음이 나타납니다.
Environment
- 윈도우 운영체제
- 글로벌프로텍트 에이전트
Cause
원인 1:
- 디폴트 으로 서비스 제어 관리자는 부팅 중에 서비스의 응답을 위해 30,000밀리초(30초) 동안 기다립니다.
- PanGPS 서비스가 구성된 타임아웃 내에 응답하지 않으면 오류 메시지가 표시됩니다.
원인 2:
PanGPS 서비스를 제대로 시작하려면 일부 종속 서비스가 필요하며, 이러한 종속 서비스는 자동으로 시작되도록 설정되어야 합니다.
Resolution
원인 1에 대한 해결책:
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control 레지스트리를 엽니다.
- DWORD 레지스트리 값 ServicesPipeTimeout을 60000(60초) 이상으로 180000(180초)으로 구성합니다.
- 이 타임아웃 증가로 서비스는 응답할 충분한 시간을 얻으므로 타임아웃 되지 않습니다. 자세한 내용은 Microsoft 설명서를 참조하세요.
- Win+R을 누르고 services.msc를 입력한 다음 Enter를 누릅니다.
- PanGPS 서비스를 찾으세요.
- PanGPS를 마우스 오른쪽 버튼으로 클릭하고 속성을 선택합니다.
- 시작 유형이 자동으로 설정되어 있는지 확인하세요.
- 종속성 탭으로 이동하여 모든 종속 서비스도 자동으로 시작되도록 설정되어 있는지 확인하세요.
Windows 관리 계측
원격 프로시저 호출(RPC)
DCOM 서버 프로세스 런처
RPC 엔드포인트 매퍼
Additional Information
Windows Management Instrumentation(WMI)을 재설정하고 다시 등록하는 방법