システムの再起動後に PanGPS サービスが開始されない
42144
Created On 07/15/22 01:44 AM - Last Modified 01/07/25 13:30 PM
Symptom
- GlobalProtect (GP) エージェントの接続ボタンは、再起動後に機能しません。
- GP エージェントに「GlobalProtect サービスに接続できませんでした。GlobalProtect サービスが実行されていることを確認してください。」というエラーが表示されています。
- コンピューターのシステム イベント ログには、タイムアウトに達したため PanGPS サービスの開始に失敗したことが示されています。
Environment
- Windows OS
- グローバルプロテクトエージェント
Cause
原因1:
- デフォルトでは、サービス コントロール マネージャーは起動中にサービスが応答するまで 30,000 ミリ秒 (30 秒) 待機します。
- PanGPS サービスが設定されたタイムアウト内に応答しない場合は、エラー メッセージが表示されます。
原因2:
PanGPS サービスが適切に起動するには、いくつかの依存サービスが必要であり、それらの依存サービスは自動的に起動するように設定する必要があります。
Resolution
原因 1 の解決策:
- レジストリHKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control を開きます。
- DWORD レジストリ値ServicesPipeTimeout を60000 (60 秒) またはそれ以上の値 180000 (180 秒) に設定します。
- このタイムアウトの増加により、応答するのに十分な時間が得られるため、サービスはタイムアウトしなくなります。詳細については、 Microsoft のドキュメントを参照してください。
- Win + R を押して、services.msc と入力し、Enter を押します。
- PanGPS サービスを見つけます。
- PanGPS を右クリックして、[プロパティ] を選択します。
- スタートアップの種類が自動に設定されていることを確認します。
- [依存関係] タブに移動し、すべての依存サービスも自動的に開始するように設定されていることを確認します。
Windows 管理インストルメンテーション
リモート プロシージャ コール (RPC)
DCOM サーバー プロセス ランチャー
RPCエンドポイント マッパー
Additional Information
Windows Management Instrumentation (WMI) をリセットして再登録する方法