Prisma SaaS is not detecting any assets from connected cloud applications
261
Created On 06/30/22 15:59 PM - Last Modified 11/11/25 23:29 PM
Symptom
Whenever user onboards cloud applications to the Prisma SaaS, the applications shows successfully connected but assets are not detected.
Environment
Prisma SaaS
SaaS Security API
DLP
Cause
This issue is caused due to wrong assignment of Super Admin role granted to the google account .
Resolution
During such situations after troubleshooting from worker logs , the first step is to delete and re-add the application and make sure to use a SuperAdmin role granted to the account and also follow the following steps:
- Ensure that you have a Google admin account with Super Admin role
- Add the Google admin account to SaaS Security API and assign a Super Admin role.
- Add the Gmail app to Google Marketplace and SaaS Security API.
- Grant Gmail API access to SaaS Security API.