Upgrade all Defenders on Prisma Cloud Compute Console

Upgrade all Defenders on Prisma Cloud Compute Console

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Created On 06/27/22 19:55 PM - Last Modified 02/07/25 21:02 PM


Symptom


  • Upgrade all button is grayed out on the Prisma Cloud Console


Environment


  • Prisma Cloud Compute Edtion 
  • Prisma Cloud SaaS 
  • Container and DaemonSet Upgrade 

    Prerequisites: You've created a Kubeconfig credential for your cluster so that Prisma Cloud can access it to upgrade the Defender DaemonSets



Cause


  • Upgrade all buttons depends on the types of Defenders on the Prisma Cloud Console 


Resolution


  •  The upgrade all button is for standalone Container Defenders only and not for DaemonSet Defenders, and the DaemonSet defenders need to be upgraded manually. Please see the document                                                                                                                                                              image.png
  • If you can't access your cluster with kubectl or oc, then you can upgrade Defender DaemonSets directly from the Console UI.
    • Please follow the prerequisite mentioned above
      • Log into Prisma Cloud Console. 
      • Go to Manage>Defenders>Manage
      • Click DeamonSets
      • For each cluster in the table, click Actions>Upgrade. The table shows a count of deployed Defenders and their new version number. For more information, please see the following document

              image.png



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