Unable to restart a job after an error occurs in Device Security Security Network Discovery plugin

Unable to restart a job after an error occurs in Device Security Security Network Discovery plugin

1808
Created On 03/19/25 04:29 AM - Last Modified 06/12/25 03:45 AM


Symptom


14:35:32.234 +0900 INFO: [neighbor_discovery] Start Neighbor Discovery for: 192.168.88.234
14:35:33.456 +0900 ERROR: [neighbor_discovery] Error while getting LLDP/CDP neighbors: 'node_device_id'
  • SNMP packet capture indicates that there are no get-next response of the following OIDs
    • CDP : 1.3.6.1.4.1.9.9.23.1.2.1.1.6 (cdpCacheDeviceId)
    • LLDP: 1.0.8802.1.1.2.1.4.1.1.9 (lldpRemSysName)


Environment




Cause


  • The issue is related to missing DeviceId/SysName information in the SNMP response from the target host.
  • The Network Discovery plugin is unable to retrieve the necessary data, resulting in the error "Error while getting LLDP/CDP neighbors: 'node_device_id'" and further process is stopped.


Resolution


  1. Rebooting the firewall resolves the issue.
  2. Executing "request plugins reset-plugin plugin-name network_discovery" also resolves the issue.
  3. Fix is implemented in this version the Network Discovery Plugin 2.2.0. Upgrading will fix the issue.
  4. If the issue is seen after upgrade the plugin to version 2.2.0 or later, open a case with Support.

 



Additional Information


Note: Executing the command "request plugins reset-plugin plugin-name network_discovery" from the NGFW's CLI allows the job to be restarted without requiring a firewall reboot.



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